#
It is currently Sat Aug 30, 2014 7:19 pm


Post a new topicPost a reply Page 3 of 3   [ 53 posts ]
Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Wed Jan 02, 2013 4:55 pm 
User avatar

Joined: Tue Aug 02, 2011 7:30 am
Posts: 45
Location: Colorado Springs, CO
Have you checked the setting on the TPS? Also the temp sensor on the back of the water pump housing?

I was just looking at the troubleshooting section of the shop manual for the GSL-SE fuel system. It says that the problem of a flooding motor and no start is either leaking injectors or a wire short in the injector wiring. I would think your problem would be in the wiring between the control unit and the injectors. You could also have a problem in the control unit itself. There is a breakdown on how to test all of these parts in the manual itself. I can send you a link to the manual that I have if you need it.

_________________
1984 Mazda RX-7 GSL-SE, 1964 Ford Galaxie 500XL 390 Auto A/C, 1970 Ford F250 Explorer 390 Auto Long Bed
My Car Blog: http://chrischillino.com/


Top
 Profile  
 
 Post subject: 1984 RX7 12a turbo GT
PostPosted: Wed Jan 02, 2013 5:47 pm 

Joined: Tue Jan 18, 2011 11:47 am
Posts: 68
Location: Auckland, New Zealand
thanks Chris, i will check it again, it was a running engine before i pulled it apart and it started so well it wouldn't even turn over once and it would go


Top
 Profile  
 
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Thu Jan 10, 2013 8:17 am 
User avatar

Joined: Tue Aug 02, 2011 7:30 am
Posts: 45
Location: Colorado Springs, CO
any luck?

_________________
1984 Mazda RX-7 GSL-SE, 1964 Ford Galaxie 500XL 390 Auto A/C, 1970 Ford F250 Explorer 390 Auto Long Bed
My Car Blog: http://chrischillino.com/


Top
 Profile  
 
 Post subject: 1984 RX7 12a turbo GT
PostPosted: Fri Jan 11, 2013 12:56 am 

Joined: Tue Jan 18, 2011 11:47 am
Posts: 68
Location: Auckland, New Zealand
Hi Chris, in a word no, i have tried everything i can and still no result so i have walked away from this one at the mo and been doing small things on the other cars, it's summer and holidays at the moment so i have been enjoying the great weather and playing with the cars that go verses the one that doesn't, i have been thinking that it might be an earth issue? what do you think?


Top
 Profile  
 
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Fri Jan 11, 2013 7:59 am 
User avatar

Joined: Tue Aug 02, 2011 7:30 am
Posts: 45
Location: Colorado Springs, CO
It could be an earth issue. I wouldn't hurt to check.

This is for the GSL-SE but it is basically the same system:
http://i293.photobucket.com/albums/mm71 ... ooting.jpg

_________________
1984 Mazda RX-7 GSL-SE, 1964 Ford Galaxie 500XL 390 Auto A/C, 1970 Ford F250 Explorer 390 Auto Long Bed
My Car Blog: http://chrischillino.com/


Top
 Profile  
 
 Post subject: 1984 RX7 12a turbo GT
PostPosted: Mon Mar 25, 2013 1:18 pm 

Joined: Tue Jan 18, 2011 11:47 am
Posts: 68
Location: Auckland, New Zealand
Well after a few months and more than a few hundred dollars later it now goes! (well sort of)

thanks rx-7 chris for your help, still don't really know what the issue is after changing the tps, water temp, earth, afm, injector plugs and countless settings,
i'm still not happy with it, it idle's to high and everyday i start it i get a different result, from running perfect to a pile of shit and everything in between.


Top
 Profile  
 
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Tue Mar 26, 2013 10:39 am 
User avatar

Joined: Wed Jan 18, 2012 11:59 am
Posts: 36
Location: Seattle
rx4rx7 wrote:
Well after a few months and more than a few hundred dollars later it now goes! (well sort of)

thanks rx-7 chris for your help, still don't really know what the issue is after changing the tps, water temp, earth, afm, injector plugs and countless settings,
i'm still not happy with it, it idle's to high and everyday i start it i get a different result, from running perfect to a pile of shit and everything in between.



I LOVE your attention to detail. Interestingly enough, before even seeing this thread I had planned on an identical color scheme for my engine build! Brilliant minds, eh? :wink:

1) have you replaced the O2 sensor?
2) Do you have a wideband O2 sensor - if so, hows it look? Running too rich all the time, or sporradic?
3) Have you cleaned the gas tank?

That it runs sometimes and not others may definitely seem like a ground. I also think it could be the injectors may not be firing correctly - again could be an intermittent ground issue. Did you replace the harness during the build or use the factory? Even if it was running before, a 30 year old wire could be brittle, and the sheath may look OK but the wire itself broken enough to sometimes lose connection.

Perhaps run a new ground wire to all of the injectors? I'm looking at the wiring diagram for the GSL-SE now, and trying to determine if they are ground actuated injectors, meaning the ECU closes the ground loop to fire the injector. I'm not sure. Will keep looking. But basically i think you'd have to run a new ground from each injector back to the ecu harness plug.

Here's what I'm looking at:
http://foxed.ca/index.php?page=rx7manual#firstgen page 30 in the right-middle, B-30 and B-31

Let me see if i can dig up the method for testing if the injectors are firing...

Here we go: page 58 of section 4B of 1985 FSM. Granted this is GSL-SE 13b US spec, but the methods should be the same:
https://docs.google.com/file/d/0B4M7Prx ... 3soK&hl=en
- or from the menu here -
http://foxed.ca/rx7manual/85_manual_google.html

_________________
1984 RX-7 5-letter


Top
 Profile  
 
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Tue Mar 26, 2013 12:18 pm 
User avatar

Joined: Wed Jan 18, 2012 11:59 am
Posts: 36
Location: Seattle
I also wanted some more info on the nickel plating - is this something you're DIY'ing or are you sending it to be plated?

If there's an at-home kit for this, i'm so doing this. All the paints i've found that match the color are not hi-temp safe.

_________________
1984 RX-7 5-letter


Top
 Profile  
 
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Tue Mar 26, 2013 3:30 pm 
User avatar

Joined: Wed Jan 18, 2012 11:59 am
Posts: 36
Location: Seattle
Actually after thinking on it for a while - verify that your ECU is grounded properly.

_________________
1984 RX-7 5-letter


Top
 Profile  
 
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Thu Mar 28, 2013 7:38 pm 

Joined: Tue Jan 18, 2011 11:47 am
Posts: 68
Location: Auckland, New Zealand
thanks for all the info, it seems to be running ok today but the idle is still a bit high,
the o2 and all the other sensors are working fine but it does have a very bad vibration, i think the guy that ground the flywheel made a cock up so that will be the next thing to do after finding some replacement rear tyre's for the old and original re71's.
the plating is done by a guy that my company puts a lot of work through, he does it as a cash job or a box of beer's,
so here are some pics of the finished item, i think that makes the engine bay complete now

Image

Image

Image




thanks again for looking


Top
 Profile  
 
 Post subject: 1984 RX7 12a turbo GT
PostPosted: Thu Mar 28, 2013 7:42 pm 

Joined: Tue Jan 18, 2011 11:47 am
Posts: 68
Location: Auckland, New Zealand
Image


Top
 Profile  
 
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Thu Mar 28, 2013 9:48 pm 

Joined: Tue Feb 05, 2013 12:58 am
Posts: 8
Wow!! looks great so far. :tu:


Top
 Profile  
 
 Post subject: Re: 1984 RX7 12a turbo GT
PostPosted: Mon Apr 01, 2013 9:34 am 
User avatar

Joined: Tue Aug 02, 2011 7:30 am
Posts: 45
Location: Colorado Springs, CO
That looks really good.

_________________
1984 Mazda RX-7 GSL-SE, 1964 Ford Galaxie 500XL 390 Auto A/C, 1970 Ford F250 Explorer 390 Auto Long Bed
My Car Blog: http://chrischillino.com/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 3 of 3   [ 53 posts ]
Go to page Previous  1, 2, 3


Who is online

Users browsing this forum: cycleway4 and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net