#
It is currently Mon Dec 22, 2014 3:09 pm


Post a new topicPost a reply Page 1 of 1   [ 4 posts ]
Author Message
 Post subject: 81 Celica - 22R Motor - Will not stay running
PostPosted: Sat Apr 09, 2011 7:23 pm 
User avatar

Joined: Fri Jun 12, 2009 6:47 pm
Posts: 96
Location: Union, NJ
Ok, so the weather finally nice and had time to look at the car.

Problem: car runs but will only run 6-10 mins tops then dies and will have to sit for a while before I start it again.

I checked: Fuel getting in carb ok, did not see any vacuum leaks or disconnected vacuum hoses.

I changed: Mechanical fuel pump, fuel filter, plug wires + ignition coil wire, new battery, cap, rotor, air filter too

I was asked on another forum if ignition coil overheating, did not notice to be too hot, but had a damp rag and put on top of coil when temp feels a little hot. Could it be the coil and igniter (ICM)?

If it's the coil, what's the best alternative to replace the coil and igniter. I checked the ICM and it's about $300 at rockauto.

I've seen an MSD 6A (6200) + Coil Blaster 2 on an 81 Celica. Will this setup work? How hard is it to re-wire for the MSD & Coil?
Anyone has the correct part numbers to buy for the setup.

Thanks in advance to everyone that comments


Top
 Profile  
 
 Post subject:
PostPosted: Sat Apr 09, 2011 8:44 pm 
JNC Enthusiast

Joined: Mon Jun 08, 2009 9:26 pm
Posts: 794
Location: Melbourne, Australia
how's the weather in NJ (New Jersey?) now? you guys at in Spring? Only asking as the fuel may be vaporising.

Check the distributor as well. I had the exact same problem on a Ford Laser once (they were sold in the US as well, no idea under what name though). Turned out that a diode or something similar inside the distributor would get hot after a few minutes of running and kill the spark. Only worked it out as a auto electrician friend had the exact same problem on the same model car a week earlier!

_________________
occasional blog: http://ewokracing.tumblr.com

Brought to you by me as I search Alta Vista for Geocities webpages using Netscape Navigator while listening to Jam & Spoon.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Apr 10, 2011 6:33 am 
User avatar

Joined: Fri Jun 12, 2009 6:47 pm
Posts: 96
Location: Union, NJ
Yup, it's spring with about low 50's - 60's.

I got a suggestion of doing an OHM test on the pickup-coil in the distributor. But since the pickup coil and new coil is not that much may be wise to change it.


Thanks


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 15, 2011 8:06 pm 
User avatar

Joined: Fri Jun 12, 2009 6:47 pm
Posts: 96
Location: Union, NJ
It turned out to be a bad ignition coil. Runs like how it should now :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 4 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net