#
It is currently Mon Sep 15, 2014 2:43 am


Post a new topicPost a reply Page 1 of 1   [ 20 posts ]
Author Message
 Post subject: 79' Celica Project Build !!
PostPosted: Thu Feb 18, 2010 7:30 pm 
User avatar

Joined: Thu Feb 18, 2010 7:15 pm
Posts: 10
Location: Australia, Canberra
Hello to everyone,

I have just purchased a 1979 Toyota Celica, Series 2, RA40, 2 Litre, 5 speed manual...

I got the car for free! YAY!
I love it, It needs a bit of work to make it good, but considering that it was free i will spend some money to get it going all good!

Where should I start? What are the first things I should do to get it running and working all good?
Also the ignition barrel does not go into START position, I think ill just wire up a push button switch? What wire to What?

Here are some pictures:

Image

Image

Image

Image

Image

Image

Image

Let me know what you think!
Mati


Top
 Profile  
 
 Post subject: Re: 79' Celica Project Build !!
PostPosted: Thu Feb 18, 2010 7:34 pm 
Moderator
User avatar

Joined: Fri Oct 12, 2007 8:57 pm
Posts: 8523
Location: Arlington, TX, USA
mmustillo wrote:
Also the ignition barrel does not go into START position, I think ill just wire up a push button switch? What wire to What?


You'd be A LOT better off to just buy a new ignition switch. :wink:


Top
 Profile  
 
 Post subject: switch
PostPosted: Thu Feb 18, 2010 7:43 pm 
User avatar

Joined: Thu Feb 18, 2010 7:15 pm
Posts: 10
Location: Australia, Canberra
heya,

thanks for that,
The ignition barrel is stuffed and i need to start the car.
I would like to have a buton for the starter..

i can have a few switches, 1 for ACC like radio and stuff
1 for Igniton ON, and 1 as a push button starter.

But what wires with what?
could you help me?
and what do you think about the car?

_________________
RtR - Ready to Ride


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 18, 2010 8:26 pm 

Joined: Thu Feb 04, 2010 5:16 pm
Posts: 48
Location: st louis mo
what!!! :shock: for free?! looks great! what are you planning of doing with it?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 18, 2010 8:31 pm 
User avatar

Joined: Thu Feb 18, 2010 7:15 pm
Posts: 10
Location: Australia, Canberra
silveradobeast wrote:
what!!! :shock: for free?! looks great! what are you planning of doing with it?


This lady was trying to sell it for 1200$, 3 weeks later i see it advertized for 200.. I go there and I was like... This car has so many problems, and we could not start it.. ignition barel stuck.

So she just said take it, I want it gone.. I was like SWEET!

The car needs a fair bit of work to make it nice and all good.
First i need to register it... hope all the ball joints and suspension are OK.
What mods do you reccomend doing?

Thanks!

_________________
RtR - Ready to Ride


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 18, 2010 8:56 pm 

Joined: Thu Feb 04, 2010 5:16 pm
Posts: 48
Location: st louis mo
well we all different ideas of a celica

i always loved fast powerfull cars and when the name celica come out most of the people dont take it serious
with that said im bouilding a total sleeper im going to drop a 1uz with a w58 just to wake the old celica up
i just bought my first celica and have done nothing to it (no garage) and its been super cold
but im preparing my self with some tools for the summer
here is my beater!

http://www.japanesenostalgiccar.com/for ... php?t=8438


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 19, 2010 2:28 pm 

Joined: Thu Aug 27, 2009 1:57 pm
Posts: 123
Location: delavan,WI
Car looks realy nice! And for being free i cant see where you can go wrong. man wish we got the chrome bumpers.

_________________
1981 celica gta
1983 civic 1500 (DD)
1987 nissan 200sx (sold)
1971 celica....rusty


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 19, 2010 2:28 pm 

Joined: Thu Aug 27, 2009 1:57 pm
Posts: 123
Location: delavan,WI
Car looks realy nice! And for being free i cant see where you can go wrong. man wish we got the chrome bumpers.

_________________
1981 celica gta
1983 civic 1500 (DD)
1987 nissan 200sx (sold)
1971 celica....rusty


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 19, 2010 2:46 pm 
User avatar

Joined: Tue Aug 26, 2008 8:21 am
Posts: 72
Location: Cuyahoga Falls, Ohio
You lucky Aussies and your chrome bumpers. Seems like a decent start for a project. Can't beat that price either!


Top
 Profile  
 
 Post subject: Alternator Problem?
PostPosted: Fri Feb 19, 2010 4:22 pm 
User avatar

Joined: Thu Feb 18, 2010 7:15 pm
Posts: 10
Location: Australia, Canberra
Hey,

Ok, SO i started working on the car, I need to get it registered and going.

It has a New Alternator with a Regulator (this shiny box on the side).
Also has a 325CCA batery, that is new also.. ( But completaly dead/not charged)

I CAN JUMP start the car with leads, but once i disconnect the leads the car dies and turnes off.. It seems like the alternator is not charging and giving power to the car?? whats the problem?

Where should I look?
Thanks!

_________________
RtR - Ready to Ride


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 19, 2010 7:34 pm 
User avatar

Joined: Mon Oct 13, 2008 9:33 pm
Posts: 213
Location: Forty-Fort, PA
Jump the car and check the alt while it is running...


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 19, 2010 8:01 pm 

Joined: Tue Dec 18, 2007 9:10 pm
Posts: 594
Location: Brunei
nice 2nd gen celica

what more can you ask? its free, wish someone give me a free celica :D

_________________
http://bruneiclassiccelica.com/


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 20, 2010 7:59 pm 
Administrator
User avatar

Joined: Thu Jan 18, 2007 5:41 pm
Posts: 5591
Location: LA
Welcome to JNC. Nice score!

To start with, get a multimeter and check the voltage at the battery terminals. Should be 12V when off, around 16 when running. If it's less than 16, the alternator needs to be replaced.

As others have said with the ignition switch, it's MUCH easier to replace the switch than wire up some buttons. I wouldn't know where to begin telling you how to wire it with buttons.

Good luck.

_________________
Tyler wrote:
How I long for a shit brown wagon.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 21, 2010 12:53 am 

Joined: Sun Feb 01, 2009 5:10 am
Posts: 232
Location: Northridge, CA
16???

The charging voltage should be 13.8V-14.2V.


Top
 Profile  
 
 Post subject: Its starts and works!
PostPosted: Sun Feb 21, 2010 8:22 pm 
User avatar

Joined: Thu Feb 18, 2010 7:15 pm
Posts: 10
Location: Australia, Canberra
Ok,

So i fixed the ignition barrel, i took it all appart, took some pliers and just foced the barrel to turn all the way to START position.
I assembeled everything back and it all works beautifully! YAY.

about the Charging system:
The car starts now! The ragulator is nice and shiny and new. I took it apart and it was all rusty inside (water got in...)! Blown Fuse! what fuse is supposed to be there? Now i have just a metal wire there.
The car charging system shows me about 16-17 Volts when charging...
Is that wrong??
and my Volt dash Gague also does not work! why?

Thanks for the help!

_________________
RtR - Ready to Ride


Top
 Profile  
 
 Post subject: Re: Its starts and works!
PostPosted: Sun Feb 21, 2010 8:58 pm 
Moderator
User avatar

Joined: Fri Oct 12, 2007 8:57 pm
Posts: 8523
Location: Arlington, TX, USA
mmustillo wrote:
The car charging system shows me about 16-17 Volts when charging...
Is that wrong??


Yes, it should not exceed 14.5 under most conditions. If it's that high, chances are the voltage regulator is not doing it's job correctly.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 21, 2010 9:34 pm 
User avatar

Joined: Thu Feb 18, 2010 7:15 pm
Posts: 10
Location: Australia, Canberra
so if the car is charging like 16 volts is it bad?
what can get damaged? so you think the regulator is bad...?

_________________
RtR - Ready to Ride


Top
 Profile  
 
 Post subject: Engine Service Time
PostPosted: Thu Feb 25, 2010 5:50 pm 
User avatar

Joined: Thu Feb 18, 2010 7:15 pm
Posts: 10
Location: Australia, Canberra
Hey Guys,

Before I drive the car much, I want to give it a good service.

Engine, 5sp Tranny, Diff whise, What should i do?

I will be replacing all the Fluids, plugs, rotor, cap....

What oil do you reccomend?

And what else should I do and Service?
Car drives bad and rugh now...

Thanks a lot!
Mati

_________________
RtR - Ready to Ride


Top
 Profile  
 
 Post subject: Car is running!
PostPosted: Thu Mar 04, 2010 7:37 pm 
User avatar

Joined: Thu Feb 18, 2010 7:15 pm
Posts: 10
Location: Australia, Canberra
Hey Guys,

So i Got the car registered and running nicely.
I changed most of the ignition components, so the car runs good.

There is one problem:
The car is using way to much fuel. I fill up with 15 bucks, 12 Liters of 98 octane, and I can barely do 50 kms... what could this be?
I think my carby needs a good tune up?

What else can i do to gain a bit more power?
From 4,000RPM to 5500RPM there is no power gain.. it just stays the same..

Thanks!
Mati

_________________
RtR - Ready to Ride


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 08, 2010 5:58 pm 

Joined: Wed Oct 22, 2008 5:33 pm
Posts: 96
Location: Manila, Philippines
mmustillo wrote:
so if the car is charging like 16 volts is it bad?
what can get damaged? so you think the regulator is bad...?


overcharging will shorten the battery's life

you also probably need to have the carburator cleaned to improve fuel consumption


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 20 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net