#
It is currently Mon Apr 21, 2014 1:00 am


Post a new topicPost a reply Page 1 of 1   [ 5 posts ]
Author Message
 Post subject: Having some clutch issues on a 77' corona w50 trans...help!
PostPosted: Sat Feb 06, 2010 4:55 pm 
User avatar

Joined: Mon Oct 13, 2008 9:33 pm
Posts: 212
Location: Forty-Fort, PA
So I installed a brand new clutch/pressure plate/throwout and input shaft bearing(had the flywheel resurfaced) in my w50/20r equipped rt105. Drove the car about 6000 miles and all was well.

I then decided to put an 86 22r in place of the smoking 20r.

So I just bolted all of the 20r clutch/flywheel/trans parts to the 22r.Seemed to work fine,but I did notice all of the clutch adjusters had to be maxed out(master/slave)..and now the clutch grabs right at the top of the pedal travel,and is bothering me.

Question is,are these parts compatable?do I need a different cluch arm?throwout bearing different widths?flywheel not thick enough?Flywheel machined wrong?

Help! It is making me crazy :(


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 07, 2010 12:03 am 

Joined: Sun Feb 01, 2009 5:10 am
Posts: 232
Location: Northridge, CA
Dude, the flywheel/clutch/bellhousing/fork/master-slave/pedal are the same as what you had before...only the ENGINE changed. Sounds like your clutch is kaput.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 07, 2010 10:51 am 
User avatar

Joined: Mon Oct 13, 2008 9:33 pm
Posts: 212
Location: Forty-Fort, PA
I was just worried about 22r/20r differences....I'll pull her apart and check now.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 07, 2010 1:14 pm 

Joined: Sun Feb 01, 2009 5:10 am
Posts: 232
Location: Northridge, CA
The distance from the bellhousing mating flange on the back of the block and the flywheel mating surface on the crank is the same. You used all your 20R parts, right?


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 07, 2010 4:03 pm 
User avatar

Joined: Mon Oct 13, 2008 9:33 pm
Posts: 212
Location: Forty-Fort, PA
Yep...only thing that changed was the engine.Actually seems like when i start the car in the morning it is fine and as the day goes on it the clutch grabs taller and taller...Make sense?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 5 posts ]


Who is online

Users browsing this forum: 02Anders and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net