#
It is currently Thu Nov 27, 2014 4:11 am


Post a new topicPost a reply Page 1 of 1   [ 3 posts ]
Author Message
 Post subject: My 1993 Rodeo S
PostPosted: Tue Jun 19, 2012 6:37 am 
User avatar

Joined: Fri Jul 30, 2010 12:53 am
Posts: 16
Location: Richmond Va
Bought a 1993 Rodeo. 155k miles, A/c works, some body dings. Fixed one coolant leak and another one started. Fixed that coolant leak then found out the weep hole on the water pump was leaking. Removed the timing belt cover and noticed 3 inches of slack in the belt. Firewall sticker said next the timing belt was due for replacement at 145k. Replaced the belt with an ITM version and a NTN hyd tensioner. The old tensioner wasnt even touching the pulley and you could compress it with you thumb by one hand.

Fixed all the timing components and noticed it runs alot better. "First timing belt" total pain in the a--. I'm use to chains. After replacing the belt I noticed it doesnt pop through the intake and has tons of more power. So I assume it jumped before replacing it. Still need to fix a few odds and ends. I did use Prestone coolant flush before fixing all the leaks. Didnt have to drain it when it leaks out by itself. Went out to the junkyard and got a Reese Class 3 Hitch for 25 bux. Installed that today, still need to tighten one bolt.

Pics coming in few days.

Stuff I have done since I had it.

Timing Belt/Water Pump Replace at 155K
Alternator Belt Replaced at 155K
Power Steering Pressure Hose at 155K
Ngk Spark Plugs at 155K
Ngk Plug Wires at 155K
Rotella T6 Oil at 155K
Fram Tough Guard Oil Filter at 155K
Optima Red Top Battery at 155K
Replaced the coolant overflow tank at 155K
Reese Class 3 Hitch at 155K
Removed the cluster green bulb condoms 155K
Cleaned the trash from the blower motor at 155K
New 235/75/15 Mud & Snow Tires at 155K
Replaced the Power/Winter Switch at 155K

Front Brake Pads at 156K
Added Silverstar Ultra 9004 Bulbs at 156K
Purolator Fuel Filter at 156K
Replaced Fram Oil-F with K&N at 156K
Replaced 180 Thermostat with 170 at 156K
Replaced Radiator Cap at 156k
Replaced Fan Clutch at 156K

Replaced CTS "Ecu" at 157K
Replaced Crank Sensor at 157K
Replaced Lower End Gasket Set at 157K
Replaced Intake Manifold Gaskets at 157K
Replaced Valve Cover Gaskets at 157K
Replaced One DIS Coil at 157K
Replaced Rotella T6 at 157K
Replaced K&N Oil Filter at 157K

Replaced all 4 shocks at 160K
Aftermarket Brush Guard at 160K
K&N Panel Filter at 160K

Image

Image

Image

Image

Image

Image

_________________
Daily Driver "87 Conquest TSI" which is my 9th one.


Top
 Profile  
 
 Post subject: Re: My 1993 Rodeo S
PostPosted: Tue Jun 19, 2012 10:07 am 

Joined: Thu Aug 12, 2010 4:15 pm
Posts: 143
Location: Reno, NV
Nice, glad to see more Isuzus on here!

Bart

_________________
http://www.isuzugeek.org
Image
http://isuzugeek.blogspot.com/


Top
 Profile  
 
 Post subject: Re: My 1993 Rodeo S
PostPosted: Fri Dec 27, 2013 7:54 pm 

Joined: Tue May 14, 2013 10:00 am
Posts: 4
Location: Denver, Colorado
Nice car, still work well?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 3 posts ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net