Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 67 Corona Help

  1. #1
    Senior Member
    Join Date
    May 2010
    Location
    Springfield, OR
    Posts
    100

    67 Corona Help

    about a year ago my dads Rona died... While i was driving it. It wouldnt spark, turns out it was the ignition. So we switched that out and it still wont run.

    Specs
    Bone stock 3r-c with toyoglide 2 speed.

    New Stuff.
    Coil
    Rotor
    Cap
    Plugs
    Rebuilt Carb
    Ignition Switch
    Condenser

    So heres the problem.
    It will crank over, we have strong spark. It will keep cranking and it'll act like its going to start but it will never actually run. We are starting to get fed up with it and dont have a clue what to do. So im wondering if anyone can shed some light on this subject, Is this a common problem with these cars?

  2. #2
    Member
    Join Date
    May 2010
    Location
    California
    Posts
    59

    Re: 67 Corona Help

    You getting fuel? if you can't tell, pull the aircleaner off and drip a few drops of fresh clean gas down into the carb and see if it changes anything. just dont drop too much in there =p.

  3. #3
    Senior Member
    Join Date
    May 2010
    Location
    Springfield, OR
    Posts
    100

    Re: 67 Corona Help

    Quote Originally Posted by adamyee
    You getting fuel? if you can't tell, pull the aircleaner off and drip a few drops of fresh clean gas down into the carb and see if it changes anything. just dont drop too much in there =p.
    Already been tried. In the little peep hole on the side of the carb the level stays pretty much the same... if anything we are getting to much, but i doubt it.

  4. #4
    Senior Member
    Join Date
    May 2010
    Location
    Springfield, OR
    Posts
    100

    Re: 67 Corona Help

    Quote Originally Posted by asirike20
    surely there is a problem with the carb..........
    maybe it is blocked..............
    I dont think so because if i look through the butterflies i can see fuel at the bottom of the intake... :?
    Could the intake get clogged somehow?

  5. #5
    Junior Member
    Join Date
    Oct 2009
    Location
    Sacramento, CA
    Posts
    14

    Re: 67 Corona Help

    Check the timing??? I'm just sayin :tu:

  6. #6
    Senior Member
    Join Date
    May 2010
    Location
    Springfield, OR
    Posts
    100

    Re: 67 Corona Help

    Quote Originally Posted by Garlic Cruton
    Check the timing??? I'm just sayin :tu:
    Ah, that leads me to another dilema. The distributor does not move... no matter how hard I try and turn it(not trying too hard for fear of breaking it).
    I'm assuming this is not normal but I'm not sure, I'm not to familiar with this engine.

  7. #7
    Member
    Join Date
    May 2010
    Location
    California
    Posts
    59

    Re: 67 Corona Help

    You are loosening the dizzy before you try and turn it right? Sorry if you take that wrong, but I've seen people try it before =P

  8. #8
    Senior Member
    Join Date
    May 2010
    Location
    Springfield, OR
    Posts
    100

    Re: 67 Corona Help

    Quote Originally Posted by adamyee
    You are loosening the dizzy before you try and turn it right? Sorry if you take that wrong, but I've seen people try it before =P
    Yes sir, Small clamp just under the dizzy holding to the block.

  9. #9
    Member
    Join Date
    May 2010
    Location
    California
    Posts
    59

    Re: 67 Corona Help

    and the thing wont budge at all? does it still slide out of the block?

  10. #10
    Senior Member
    Join Date
    May 2010
    Location
    Springfield, OR
    Posts
    100

    Re: 67 Corona Help

    Quote Originally Posted by adamyee
    and the thing wont budge at all? does it still slide out of the block?
    I haven't tried to take it out, but no, it doesn't budge when turning.
    :cry:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •