Results 1 to 7 of 7

Thread: still 3t issue

  1. #1
    Senior Member
    Join Date
    Jul 2009
    Location
    Austin
    Posts
    104

    still 3t issue

    Alright well heres the deal.

    My car either misfires or doesnt fire at all. it tends to swich in between whenever it likes. I have my assumption what are yours?

  2. #2
    Senior Member
    Join Date
    Jan 2009
    Location
    LaPine, or
    Posts
    259
    distributor 180 out?

  3. #3
    Senior Member
    Join Date
    Jul 2009
    Location
    Austin
    Posts
    104
    i doubt it... its been 180* out before and it wont even start like that

  4. #4
    Senior Member
    Join Date
    Jul 2009
    Location
    Austin
    Posts
    104
    took 3 months but shes a beast. thanks guys

  5. #5
    Administrator
    Join Date
    Jan 2007
    Posts
    3,108
    I assume you checked all the basic stuff like plugs/wires, compression, etc?

    Does it run lean?

  6. #6
    Senior Member
    Join Date
    Jul 2009
    Location
    Austin
    Posts
    104
    i replaced all that. The pos weber didnt have a return line cand the float bowl was full so it over flowed making the car uber rich shooting out black smoke and yup, fouling plugs. so it was a carb issue causing all of this. stock carb, new plugs, and lots of seafoam fixed it.

  7. #7
    Member
    Join Date
    Dec 2007
    Location
    Victoria BC Canada
    Posts
    42
    I'm pretty sure a weber carb is not supposed to have a return line. The float and float needle regulate the float level. If the carb is overflowing either the float needle is just stuck (happens if the carb is gummed up or corroded inside) or your fuel pressure is way too high (should be 3-5 psi).

Similar Threads

  1. Rx2 pitman issue
    By ozzyincali in forum Mazda Garage
    Replies: 4
    Last Post: 02-19-2014, 10:26 PM
  2. Mx32 issue
    By thatdeafguy in forum Toyota Garage
    Replies: 3
    Last Post: 07-08-2011, 12:16 AM
  3. KE30 Carb issue
    By jakob in forum Toyota Garage
    Replies: 1
    Last Post: 10-18-2010, 11:44 AM
  4. MAX POWER DEC. 2009 issue ???
    By toji004 in forum Off-Topic
    Replies: 5
    Last Post: 01-20-2010, 10:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •