Results 1 to 9 of 9

Thread: Racing Beat 465CFM on 12A Streetport Question!!!!!

  1. #1
    Member
    Join Date
    Jul 2010
    Location
    Richland, WA
    Posts
    53

    Racing Beat 465CFM on 12A Streetport Question!!!!!

    To those more knowledgeable than I,
    I currently have a Racing Beat 465CFM Carburator and Intake on my streetported 12A Mazda RX2 (RX7 motor with Electronic Ignition). I am having an extreme studder right off of idle, at about 1500 - 2500 RPM. Obviously, in any gear, this is at the RPM range where any type of normal cruising speed makes life pretty miserable. I noticed that there is no power valve in this carburator, and that there is a power valve cap. Could this be the culprit to my problem, or does anyone think it may be something else? If those of you that have knowledge about this type of subject could supply me some advice, I would truly appreciate it. In doing research on the subject, most responses lead to the power valve cap being applied for racing conditions, and I am simply wanting a street cruiser that still has the ability to take down a few of those arrogants that know nothing about these nostalgic Mazda sleepers!!!!
    If any think that it is a power valve issue, can you advise me what a typical streetported 12A needs for a power valve, as there are many different sizes available.

    Thanks so much for the help!

  2. #2
    Junior Member
    Join Date
    Feb 2009
    Location
    NORWAY
    Posts
    27

    Re: Racing Beat 465CFM on 12A Streetport Question!!!!!

    ugh, carbs are sorcery. so you need to find the nearest wizard :lol:

  3. #3
    Member
    Join Date
    Aug 2011
    Location
    Colorado Springs, CO
    Posts
    52

    Re: Racing Beat 465CFM on 12A Streetport Question!!!!!

    can you describe the actual problem a little better. I don't think it has anything to do with the power valve. Most likely a tuning problem.

    I had this same setup on a large SP 12A

  4. #4
    Member
    Join Date
    Jul 2010
    Location
    Richland, WA
    Posts
    53

    Re: Racing Beat 465CFM on 12A Streetport Question!!!!!

    rx-7 chris,
    Here is the equipment scoop:
    Engine is a 12A Streetported Rx7 motor with a Racing Beat/Holley 465CFM carburator and Racing Beat intake manifold. Engine has Electronic Ignition Distributor, and is firing from two MSD Blaster 2 coils. I initially had a problem with the trailing plugs not firing, but realized that my tachometer wire had a short somewhere, so when removing from coil connection, all firing was fixed. All timing on the ignition has been set correctly, and is firing per the marks on the pulley with proper advancement. I have checked the fuel pressure to the carburator, and I am maintaining 6psi even under high RPM load.

    Here are the symptoms:
    Car starts perfectly fine and idles as it should. Once placed into gear and I begin to take off, the car hits between 1500 - 2500 RPM and it's like the bottom falls out from it. There is a massive flat spot where the engine simply spudders and acts like it is going to die. During this time, the car is in motion, but because it seems like it is fighting for fuel, it jerks forward and backward fairly violently. At this point you either need to let off on the throttle to get it to calm down, or apply a pretty stout foot into the throttle to force it past this stage, at which the car will immediately take off quite briskly. At any given gear, this RPM range is the primary cruising range for the motor, so you can never just drive at a given speed. You either need to be into the throttle at this range, or out of the throttle to keep the motor going. Very frustrating, as this was a professionally built motor, and I feel I have chosen intake equipment with a proven track-record, but something has definately gone wrong in the process.

    I did a little bit more research on the issue, and I agree, it is not the power valve. At this point, I am at a loss, as I simply do not know that much about carburators. It's quite the shame, as I did take the car out over the weekend amidst all the problems, and was accosted by two different gentleman that were in awe of seeing an RX2 on the road. Both had identical stories to mine regarding their passion for old RX2's and RX3's, but with the difference being that they let theirs go when they were younger. I chose to keep mine, and I want to get it on the road consistently, so that others can appreciate it as much as I do.

    Any thoughts appreciated!

    Pictures of car are on page 3 of "1973 Mazda Rx2- Return from the dead project" in this same section - Mazda Garage.

    Take a look if you are interested!

  5. #5
    Member
    Join Date
    Aug 2011
    Location
    Colorado Springs, CO
    Posts
    52

    Re: Racing Beat 465CFM on 12A Streetport Question!!!!!

    Ok. You are probably right about the motor starving for fuel.

    I'll start with the basics.

    -check fuel filter
    -fuel pump is strong enough. What fuel pump are you running?
    -fuel pressure regulator set to 6 psi
    -double check timing again.

    take a look at these:
    http://www.holley.com/data/Products/Tec ... 3-2rev.pdf
    http://www.holley.com/data/TechService/ ... uretor.pdf
    http://www.holley.com/data/TechService/ ... 20Info.pdf
    http://www.bob2000.com/carb.htm

    How are you idle mixture screws set? Are they set to the richer side?

    I have a feeling that you will need to go with larger primary jets. If you pull the float bowl off the primary side, you will see the primary jets. On the side of the jets it will have a number. I think RB uses 50's. Go up by 3 size (holley recommends always jumping by 3 sizes either larger or smaller). If this gets it to run a little better but not quite there, go up another 3 size. If this makes it worse, go to 3 sizes smaller than what you started with.

    The reason it seems to stop sputtering at higher rpm is the secondaries have started to kick in and they are giving enough fuel to compansate.

  6. #6
    Member
    Join Date
    Jul 2010
    Location
    Richland, WA
    Posts
    53

    Re: Racing Beat 465CFM on 12A Streetport Question!!!!!

    Great information! I went ahead and removed the #50 primary jets and installed #56's, what a dramatic improvement over the #50's. I would say this change alone fixed the problem about 85%. Went ahead and tried #59's, but didn't get any better so went back down to #56's. Now the car is very comfortable, with just a little studder at that same RPM range as before. Significant power increase as well!!!!

    Now it will be a matter of fine tuning. I did re-check the timing, and everything is spot-on there. The idle mixture screws are set to ensure there is no studder in the idle, it is simply a very smooth idle as it was before.

    Thanks for the help, and if you have further fine-tuning advice, I am all ears.

  7. #7
    Member
    Join Date
    Aug 2011
    Location
    Colorado Springs, CO
    Posts
    52

    Re: Racing Beat 465CFM on 12A Streetport Question!!!!!

    Did you set the timing to the stock settings or what RB recommends?

  8. #8
    Member
    Join Date
    Jul 2010
    Location
    Richland, WA
    Posts
    53

    Re: Racing Beat 465CFM on 12A Streetport Question!!!!!

    Per Racing Beat specifications!

  9. #9
    Member
    Join Date
    Aug 2011
    Location
    Colorado Springs, CO
    Posts
    52

    Re: Racing Beat 465CFM on 12A Streetport Question!!!!!

    You probably just need to keep tweeking it till it's running great. I would look for vacuum leaks, etc.

Similar Threads

  1. WTB: 12A Racing Beat intake
    By Javypro in forum Mazda Swap Meet
    Replies: 0
    Last Post: 05-29-2013, 05:49 PM
  2. 13B racing beat manifold and 44mm mikuni carbs.
    By 732tg in forum Mazda Swap Meet
    Replies: 0
    Last Post: 03-27-2012, 03:04 PM
  3. Holley 465 CFM for 12A Streetport
    By Apple Guy in forum Mazda Swap Meet
    Replies: 0
    Last Post: 10-22-2010, 04:26 AM
  4. Kei Car Racing
    By vwdmc16 in forum General Discussion, JNC News & FAQ
    Replies: 5
    Last Post: 12-30-2009, 05:53 AM
  5. Racing on Rota RBs
    By Rad2Ltr in forum Resto Tips, Wheels & Other Goodies
    Replies: 13
    Last Post: 11-19-2009, 04:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •