Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: my 1980 mx32

  1. #1
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    my 1980 mx32

    i just scored a sweet cressida mx32. this thing is in nice shape with only 112k on it. Its an east coast car so there is a tad bit of rust/and paint blemishes but its still solid as far as the floors rockers and rails go


    say hello to my new daily.

    pics commin soon

  2. #2
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: my 1980 mx32

    alrighty, got the titlework done and registered it

    now its at the shop getting inspected (hope it doesnt need much, i know it needs an alignment the pass side tire wore terrible)







  3. #3
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: my 1980 mx32

    not sure why photobucket is being stupid with the sizings....


    anyways, few things im going to look at is the brakes, they squeak pretty bad when stopping... im thinking it needs shims or something since it stops fine. will probably bleed and paint the brake booster first.


    also i noticed it doesnt always fire the first time. i have to crank it quite a bit to get it to fire, but once it starts it purrs like a kitten and pulls hard.


    any thoughts on what this could be?

    starter selonoid?

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Location
    Texas
    Posts
    229

    Re: my 1980 mx32

    Does your engine have a Cold Start Injector? could be that ....

  5. #5
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: my 1980 mx32

    good point, i can definately check

  6. #6
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: my 1980 mx32

    bump... got her legal but she still needs a bit of work

    ordered the idler arm to fix the sag in the pass side suspension

    also got an exhaust manifold gasket and valve cover gasket on order.

    next is changing all the fluids, as i continue to drive her daily. got aot of comments already and shes completely stock

    she still cranks kindof hard... im thinking maybe the starter selenoids are worn out or something... once it starts it runs amazing though

  7. #7
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: my 1980 mx32

    alrighty update time!


    after dailing the cress for a few months i noticed a few things i want to take care of and improve before i do the suspension.


    first were the brakes. the stock ones were installed with no grease/shims and they would squeal horribly at every stop.

    i decided to just get new remanned calipers and pads from Napa. total cost: 120 or so. i really wish these pads came with some sort of shims but I'm not sure if its because i went with a parts store pads or what. i applied brake grease and so far there is no brake squeal.





    while i was under the car i did notice this which upsets me but i know that its not too bad. drivers fender was obviously bondo'ed and painted when they got the cheap paint job. i will have my friend patch this. if anyone has a dented fender with a good lower portion and they don't mind cutting up that would be awesome



    so this might sound really stupid, but can you cut the springs on the damper? or do you have to disassemble? i was thinking of doing that until April or so when i plan to order some sort of coil over application. I'm thinking of going with megans since i don't plan to track the car and they are assembled and just require welding onto the stock mounts.



    then i was playing dress-up hehe



    enkei 15x7 0 offset meshies



    centerlines 14x7 0ish offset


    have a lead on some tires for both sets, but I am almost done my s13 and hopefully if it sells soon i will get moving on this (if not i still will but I have my eye on another piece of J-tin) :wink:


    the other thing i noticed is my trans seems to slip a bit when the engine is cold. After the car warms up its less noticeable but it just doesn't grab very hard. I am really hoping to find the pedal assemblies at the junkyard when i go in a week or so and then i will worry about finding the w58 to switch to a five speed

    The last few months Ive noticed I have had significantly reduced my MPGs, but i plan to give the car a tune up in the next week or so. We have been having a mild winter so Im getting antsy to start working on her stay tuned

  8. #8
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: my 1980 mx32

    alrighty so i did a tune up the other day on the tired old M motor.

    new plugs, rotor, and plug wires, valve cover gasket, and finally a new thermostat to address my coolant problems

    basically the coolant looks like mud, not sure if its from the automatic trans fluid cooler leaking into the radiator or what but it looks god awful.

    before:



    the valves were super dirty and full of oil deposits



    almost after:




    now i hit a sort of snag. the top of the theromstat housing holds a cold start valve (i think) as im trying to thread the sensor on top, i stripped the fittings.... i can just tap them out to be larger, but then i also have to oblong the holes for bigger bolts for the sensor. my question is, do i really need this sensor?




    also did anyone ever clean up the stock intake on the 4me and remove some of the emission controls?




    i currently have a lead on an n/a 2jz with a five speed attached to it for a really good price; im hopefully going to scoop it up in the next week or so. It wont be going right in the car, as i want to do the suspension and what not first, but i will slowly get the motor ready then so i wont have to worry about the sluggish performance of my 4me

    any help would be great ya'll

  9. #9
    Member
    Join Date
    Mar 2012
    Location
    Long Beach
    Posts
    78

    Re: my 1980 mx32

    Clean ride. Thanks for keeping us updated. Good luck with the project.

  10. #10
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: my 1980 mx32

    no problem..... lol i might just reassemble it without that piece and see what happens... i miss driving the old girl

Similar Threads

  1. 1980 MX32 1JZ Build Up and Dyno
    By 80Cressi in forum Toyota Garage
    Replies: 26
    Last Post: 03-26-2014, 10:46 PM
  2. my first car/project 1980 mx32 cressida
    By Jelly in forum Toyota Garage
    Replies: 14
    Last Post: 11-15-2013, 05:31 PM
  3. 1980 MX32 Rear Springs
    By ManuelMTZ in forum Toyota Garage
    Replies: 6
    Last Post: 08-29-2012, 01:21 AM
  4. 1980 mx32 Cressida suspension
    By shakmx32 in forum Toyota Garage
    Replies: 32
    Last Post: 04-08-2012, 02:17 AM
  5. 1980 mx32 Cressida suspension
    By shakmx32 in forum Toyota Garage
    Replies: 0
    Last Post: 02-21-2012, 02:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •