Results 1 to 9 of 9

Thread: 1976 galant clock wiring

  1. #1
    Junior Member
    Join Date
    Mar 2010
    Location
    philippines
    Posts
    15

    1976 galant clock wiring

    looking for help, ops:
    i just want to know if anybody here knows how to wire the clock on a 76 galant?? wiring diagram might help a lot...thanks :cry:

  2. #2
    Administrator JNC's Avatar
    Join Date
    Mar 2007
    Location
    Socal
    Posts
    1,644
    isn't there just a green wire and a blue wire?
    -Matt

  3. #3
    Junior Member
    Join Date
    Mar 2010
    Location
    philippines
    Posts
    15
    where will i connect the wires?? ops:

  4. #4
    Administrator JNC's Avatar
    Join Date
    Mar 2007
    Location
    Socal
    Posts
    1,644
    how bout you show some pics of the clock and wiring?
    -Matt

  5. #5
    Senior Member
    Join Date
    Dec 2009
    Location
    Newcastle/ Australia
    Posts
    135
    This will answer your questions and more...
    http://www.sigma-galant.com/viewtopic.php?f=42&t=3280

  6. #6
    Junior Member
    Join Date
    Mar 2010
    Location
    philippines
    Posts
    15
    wow!!!!!!!!!!!that really helps, thanks a lot dave...i will soon post pics of my galant there...

  7. #7
    Junior Member
    Join Date
    Mar 2010
    Location
    philippines
    Posts
    15
    i just dismantled the clock on my galant but i found out that the wires are still connected...i am wondering why it is not working, how will i test or know if the clock is broke?? :cry:

  8. #8
    Senior Member
    Join Date
    Dec 2009
    Location
    Newcastle/ Australia
    Posts
    135
    I don't have a clock that works anymore either. The one I had in my car worked when I bought it, but stopped shortly after. The car hadn't been driven for at least 4 years before I got it.
    That's part of the reason why I replaced it with a tacho. How hard are tacho's to get in the Philippines (that is where you are from isn't it?)?

    I have a clock that goes in the console for models fitted with the tacho. It didn't work when I got it. I pulled it apart and cleaned the gears and now it works but only for about 10 seconds then stops again. I can't see any reason why it is stopping?

    Maybe try to pull it apart. See if the motor runs unloaded? It might be similar to my problem?

  9. #9
    Junior Member
    Join Date
    Mar 2010
    Location
    philippines
    Posts
    15
    Tachos were a bit hard to find here in the philippines, i tried todirectly hook up the clock into the battery and it only moves it "sec" hands a bit... :cry:

Similar Threads

  1. 1976 Colt Galant - Cleveland Ohio
    By RaptorReed in forum Ad / Auction Finds
    Replies: 3
    Last Post: 08-29-2011, 11:22 PM
  2. GS Grille for 1974 to 1976 Galant (GC)
    By pedro168 in forum Mitsubishi Swap Meet
    Replies: 1
    Last Post: 02-25-2011, 01:56 PM
  3. OEM Hubcaps for 1974 to 1976 Galant A112
    By pedro168 in forum Mitsubishi Swap Meet
    Replies: 0
    Last Post: 02-07-2011, 10:09 AM
  4. my 1976 colt galant
    By masilya in forum Mitsubishi Garage
    Replies: 7
    Last Post: 04-04-2010, 01:23 PM
  5. 1976 Colt Galant 1600GL Hardtop
    By in forum Mitsubishi Garage
    Replies: 6
    Last Post: 11-18-2009, 05:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •