Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 79 Supra no spark

  1. #1
    Member
    Join Date
    Mar 2013
    Location
    Edmonton, Alberta
    Posts
    35

    79 Supra no spark

    shootin it to see if someone might know whats up with my Supra

    long story short, i changed the cap and rotor a couple of years ago before i put it away for winter. in spring when i took it out, it ran fine for 10 minutes until it got warm, then it would jerk like crazy. eventually got frustrated and starting taking things off, dizzy cap i put on had a crack on the back of it

    put a new cap on and it ran fine, took it out for 3 hours and lost spark at 4000rpm. engine died quietly, coasted into a park thinking the distributor went. towed it home, no spark at all from any plug wires. new coil (had the original on and changed it because it was failing) and new distributor. couldnt find anything else wrong, and figured the igniter went bad being original. parts not available anymore because 1979 igniter were one year only, so i wired in a MSD 6AL and wired the EFI wire that went to the OEM igniter to its own relay with a switched 12v source. still no spark

    im thinking maybe ECU? i cant see why its not getting spark though because switched 12 volts is going to the MSD box. if anyone knows 1979's well that would be a huuuuge help lol

    also timing chain didnt break either

  2. #2
    Senior Member
    Join Date
    Oct 2011
    Location
    Alberta
    Posts
    171

    Re: 79 Supra no spark

    Still fighting with that spark issue huh? Must be getting frustrating. Keep at it, it's a beautiful car, worth the trouble. If I see you broken down in MacKinnon ravine again I'll stop by and say hi again. :wink:

  3. #3
    Member
    Join Date
    Mar 2013
    Location
    Edmonton, Alberta
    Posts
    35

    Re: 79 Supra no spark

    lol yep, all the months later no dice. i work with a guy that knows old Toyotas so at least hes gonna come over and see if he can figure out whats up. im thinking ECU because the MSD box light flickers when i crank it and its getting power.

    im not going down Groat road again in that thing, a month before you found me stalled in the park, a guy in a SUV with a couple of kayaks on top lost one and i almost smoked it

  4. #4
    Senior Member
    Join Date
    Oct 2011
    Location
    Alberta
    Posts
    171

    Re: 79 Supra no spark

    Didn't you know? It doesn't matter what you're driving, if you're on Groat Road it magically becomes a sports car.

    Good luck with the car, if I find anything at the Pick n Pull I'll let you know, I'll be there a lot this summer for my Volvo.

  5. #5
    Senior Member
    Join Date
    Apr 2011
    Location
    TX
    Posts
    283

    Re: 79 Supra no spark

    if you can't get it running right, send me your rear end. 8)

  6. #6
    Senior Member
    Join Date
    Oct 2011
    Location
    Alberta
    Posts
    171

    Re: 79 Supra no spark

    Also, throw us some eye candy. That thing is in great shape.

  7. #7
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: 79 Supra no spark

    does this have the 4me or 5me in it?

    i have two 1980 cressida ECUs, as well as a Dizzy that worked well on my car

  8. #8
    Senior Member
    Join Date
    Oct 2011
    Location
    Alberta
    Posts
    171

    Re: 79 Supra no spark

    His is the 4

    (sorry to speak for him)

  9. #9
    Senior Member
    Join Date
    Dec 2009
    Location
    southern PA
    Posts
    278

    Re: 79 Supra no spark

    its worth a shot looking at the pins/ and what not... i wouldnt see what would be different besides maybe the fuel map/rev limiter stuff like that

  10. #10
    Member
    Join Date
    Mar 2013
    Location
    Edmonton, Alberta
    Posts
    35

    Re: 79 Supra no spark

    sorry for the late reply, been busy. yeah its got a 4ME, i tried a new dizzy already but no dice. ive wanted to pull the valve cover for a while but i havent had time.

    i did buy another vehicle the other day though, 91 Crown Royal Saloon. so at last i still have something fun to drive this summer until i figure out why the Supra has no spark. no other pics of the Supra really, in the years ive owned it ive barely driven it even a few hundred kilometers.

    and sorry not giving up the rear end out of it lol, worst case is i do a engine swap on it. frame and chassis are mint on it. its got a one-off F312 open diff anyways because its very early 1979 Canadian model, only mid 79 to 81 had factory F313 LSD

Similar Threads

  1. Help please 1983 RX7 GSL no spark
    By ColoradoKP in forum Mazda Garage
    Replies: 2
    Last Post: 10-20-2013, 05:26 PM
  2. Spark plugs for a 5M?
    By dan on a plane in forum Toyota Garage
    Replies: 3
    Last Post: 07-06-2012, 05:03 AM
  3. KGC10 L20 spark plug gap
    By wookieballa in forum Datsun/Nissan Garage
    Replies: 1
    Last Post: 07-20-2011, 09:59 PM
  4. Week Spark?
    By The Names Yota, Toyota in forum Toyota Garage
    Replies: 3
    Last Post: 10-06-2010, 12:13 AM
  5. 1977 corolla no spark
    By bigblackcat in forum Toyota Garage
    Replies: 13
    Last Post: 07-20-2010, 09:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •